Сделай Сам Свою Работу на 5

Роль «бит_му_ПолныеПрава»

Изменения в конфигурации

 

Оглавление

Типовые объекты конфигурации.. 2

Подсистемы... 2

Подсистема «бит_КомИнт_УправлениеДоговорамиЗатратами». 2

Общие модули.. 2

Роли.. 6

Функциональные опции.. 13

Новые объекты конфигурации.. 14

Подсистемы... 14

Общие модули.. 14

Роли.. 20

Подписки на события.. 21

Общие макеты... 21

Перечисления.. 22

 


Типовые объекты конфигурации

Подсистемы

***- Объект изменен

-->- Объект присутствует только в конфигурации поставщика

<--- Объект присутствует только в конфигурации базы данных

^- Порядок объекта изменен

Подсистема «бит_КомИнт_УправлениеДоговорамиЗатратами»

- ***Подсистема.бит_КомИнт_УправлениеДоговорамиЗатратами

Общие модули

***- Объект изменен

-->- Объект присутствует только в конфигурации поставщика

<--- Объект присутствует только в конфигурации базы данных

^- Порядок объекта изменен

Модуль «ОбновлениеИнформационнойБазыПереопределяемый»

 

- ***ОбщийМодуль.ОбновлениеИнформационнойБазыПереопределяемый

- Модуль - Различаются значения

Изменено: 7433 - 7433

< "······СтруктураНовыхРеквизитовДокумента.Вставить("СубконтоДт"+(Сч + 1), Объект.УдалиьтДоговорКонтрагента);"

> "······СтруктураНовыхРеквизитовДокумента.Вставить("СубконтоДт"+(Сч + 1), Объект.УдалитьДоговорКонтрагента);"

 

Модуль «ОбновлениеСПредыдущейРедакции»

- ***ОбщийМодуль.ОбновлениеСПредыдущейРедакции

- Модуль - Различаются значения

Изменено: 469 – 470

< "·СоответствиеТипов.Вставить(Тип("СправочникСсылка.СтраныМира") ··· , "СправочникСсылка.КлассификаторСтранМира");"

> "·СоответствиеТипов.Вставить(Тип("СправочникСсылка.СтраныМира") ··· , "СправочникСсылка.СтраныМира");"

< "·СоответствиеТипов.Вставить(Тип("СправочникСсылка.ОсновныеСредства") ·· , "СправочникСсылка.ОсновныеСредства");"

Объект присутствует только в конфигурации базы данных: 507 - 510

"···//ВДА Временно добавленно Так как не проходило обновление "



"···Если МассивНаименованийТипов.Количество() = 0 Тогда "

"····МассивТипов.Добавить(Тип("Строка"));"

"···КонецЕсли;·"

 

Модуль «СотрудникиФормыБазовый»

- ***ОбщийМодуль.СотрудникиФормыБазовый

- Модуль - Различаются значения

Изменено: 449 – 449

< "··РедактированиеПериодическихСведений.ЗаписатьЗаписьПослеРедактированияВФорме("

> "··РедактированиеПериодическихСведений.ЗаписатьЗаписьПослеРедактированияВФорме( "

 

Модуль «УправлениеСвойствамиСлужебный»

- ***ОбщийМодуль.УправлениеСвойствамиСлужебный

- Модуль - Различаются значения

Изменено: 533 - 535

< "···Если ОбщегоНазначения.ОбъектЯвляетсяГруппой(ВладелецСвойств) Тогда"

< "····Возврат Неопределено;"

< "···КонецЕсли;"

> "···//Если ОбщегоНазначения.ОбъектЯвляетсяГруппой(ВладелецСвойств) Тогда"

> "···//·Возврат Неопределено;"

> "···//КонецЕсли;"

 

Модуль «УчетНДСБП»

- ***ОбщийМодуль.УчетНДСБП

- Клиент (управляемое приложение) - Различаются значения

Конфигурация поставщика

Значение: Ложь

Конфигурация базы данных

Значение: Истина

 

Модуль «бит_Казначейство»

- ***ОбщийМодуль.бит_Казначейство

- Модуль - Различаются значения

Объект присутствует только в конфигурации базы данных: 2391 - 2396

"·//бит_СтрунинаН +, исправление ошибки БФ - при проведении ПКО на получение наличных в банке выдает ошибку, т.к. статья не заполнена. При обновлении убрать вставку"

"·Если НЕ ЗначениеЗаполнено(СтатьяОборотов) Тогда"

"··Возврат Неопределено;"

"·КонецЕсли;"

"·//бит_СтрунинаН -"

"·"

 

Модуль «бит_МеханизмТрансляции»

- ***ОбщийМодуль.бит_МеханизмТрансляции

- Модуль - Различаются значения

Объект присутствует только в конфигурации базы данных: 1975 - 1982

"·//ВДА 25.02.12 Начало"

"·Если ЗаписьИсточник.СчетДт.Код = "20.01" И ЗаписьПриемник.СчетДт.Код = "101811" Тогда"

"··СтрокаДляПоиска = Лев(ЗаписьИсточник.СубконтоДт.НоменклатурныеГруппы.Наименование,7);"

"··ЗаписьПриемник.СубконтоДт.ОбъектыСтроительства = Справочники.ОбъектыСтроительства.НайтиПоНаименованию(СтрокаДляПоиска);"

"·"

"·КонецЕсли; "

"·//ВДА 25.02.12 Конец"

"·"

Модуль «бит_МеханизмыТиповых»

- ***ОбщийМодуль.бит_МеханизмыТиповых

- Клиент (управляемое приложение) - Различаются значения

Конфигурация поставщика

Значение: Ложь

Конфигурация базы данных

Значение: Истина

 

Модуль «бит_му_ВНА»

- ***ОбщийМодуль.бит_му_ВНА

- Модуль - Различаются значения

Изменено: 1419 - 1419

< "·"

> "·Запрос.УстановитьПараметр("ГраницаКонецПериодаПред" ,Новый Граница(КонецПериодаПредДата,ВидГраницы.Включая));//ВДА 04.09.2013"

Изменено: 1554 - 1554

< "· |····&ГраницаКон,"

> "· |····&ГраницаКонецПериодаПред,"

Изменено: 1664 - 1664

< "· ·РассчитатьАмортизацию(СтрокаПараметров);"

> "· ·РассчитатьАмортизацию(СтрокаПараметров,КонецПериода,Организация);//ВДА 04.09.2013"

Изменено: 1685 - 1685

< "Процедура РассчитатьАмортизацию(СтрокаПараметров) Экспорт"

> "Процедура РассчитатьАмортизацию(СтрокаПараметров,КонецПериода = Неопределено,Организация = Неопределено) Экспорт"

Объект присутствует только в конфигурации базы данных: 1693 - 1741

"·БалансоваяСтоимость = СтрокаПараметров.ПервоначальнаяСтоимость;"

"·СрокПолезногоИспользования = СтрокаПараметров.СрокПолезногоИспользования;"

"·Если КонецПериода <> Неопределено и Организация <> Неопределено Тогда"

"··ЛокальныйЗапрос = Новый ЗАпрос("ВЫБРАТЬ"

"·· |·ВложенныйЗапрос.ОсновноеСредство,"

"·· |·ВложенныйЗапрос.СуммаАмортизации КАК СуммаАмортизации,"

"·· |·ВложенныйЗапрос.СрокАмортизации КАК СрокАмортизации"

"·· |ИЗ"

"·· |·(ВЫБРАТЬ"

"·· |··бит_му_ПараметрыОССрезПоследних.ОсновноеСредство КАК ОсновноеСредство,"

"·· |··бит_му_ПараметрыОССрезПоследних.ЗначениеПараметра КАК СуммаАмортизации,"

"·· |··0 КАК СрокАмортизации"

"·· |·ИЗ"

"·· |··РегистрСведений.бит_му_ПараметрыОС.СрезПоследних("

"·· |····&ДатаДок,"

"·· |····Организация = &Организация"

"·· |·····И ОсновноеСредство = &ОсновноеСредство"

"·· |·····И Параметр = &ПарметрПервоначСтоимости) КАК бит_му_ПараметрыОССрезПоследних"

"·· |·"

"·· |·ОБЪЕДИНИТЬ ВСЕ"

"·· |·"

"·· |·ВЫБРАТЬ"

"·· |··бит_му_ПараметрыОССрезПоследних.ОсновноеСредство,"

"·· |··0,"

"·· |··бит_му_ПараметрыОССрезПоследних.ЗначениеПараметра"

"·· |·ИЗ"

"·· |··РегистрСведений.бит_му_ПараметрыОС.СрезПоследних("

"·· |····&ДатаДок,"

"·· |····Организация = &Организация"

"·· |·····И ОсновноеСредство = &ОсновноеСредство"

"·· |·····И Параметр = &ПарметрПервоначСрок) КАК бит_му_ПараметрыОССрезПоследних) КАК ВложенныйЗапрос");·"

"· "

"··ЛокальныйЗапрос.УстановитьПараметр("ПарметрПервоначСтоимости",ПланыВидовХарактеристик.бит_му_ВидыПараметровВНА.НайтиПоКоду("Д00000045"));"

"··ЛокальныйЗапрос.УстановитьПараметр("ПарметрПервоначСрок",ПланыВидовХарактеристик.бит_му_ВидыПараметровВНА.НайтиПоКоду("Д00000046"));"

"· ЛокальныйЗапрос.УстановитьПараметр("ОсновноеСредство",СтрокаПараметров.ВНА);"

"· ЛокальныйЗапрос.УстановитьПараметр("ДатаДок",КонецПериода);"

"· ЛокальныйЗапрос.УстановитьПараметр("Организация",Организация);"

"· Если НЕ ЛокальныйЗапрос.Выполнить().Пустой() Тогда"

"·· ТаблицаПаметровАмортизации = ЛокальныйЗапрос.Выполнить().Выгрузить();"

"·· Для каждого ТекСтрокаПарметровАмортизации Из ТаблицаПаметровАмортизации Цикл"

"··· Если ТекСтрокаПарметровАмортизации.СуммаАмортизации <> 0 Тогда"

"··· ·БалансоваяСтоимость = ТекСтрокаПарметровАмортизации.СуммаАмортизации;······ "

"···КонецЕсли; ·"

"··· Если ТекСтрокаПарметровАмортизации.СрокАмортизации <> 0 Тогда"

"··· ·СрокПолезногоИспользования = ТекСтрокаПарметровАмортизации.СрокАмортизации;······ "

"··· КонецЕсли; "

"·· КонецЦикла; "

"· КонецЕсли; "

"·КонецЕсли; ····· "

Изменено: 1748 - 1748

< "·· · СтрокаПараметров.СуммаАмортизации = БалансоваяСтоимость/СтрокаПараметров.ОстаточныйСрокАмортизации; "

> "·· · //СтрокаПараметров.СуммаАмортизации = БалансоваяСтоимость/СтрокаПараметров.ОстаточныйСрокАмортизации; ВДА 04.03.13 "

Объект присутствует только в конфигурации базы данных: 1750 - 1750

"··· СтрокаПараметров.СуммаАмортизации = БалансоваяСтоимость/СрокПолезногоИспользования;//СтрокаПараметров.СрокПолезногоИспользования;ВДА 26.03.13"

Изменено: 1753 - 1755

< "··· СтрокаПараметров.СуммаАмортизации = БалансоваяСтоимость;"

> "··· //СтрокаПараметров.СуммаАмортизации = БалансоваяСтоимость;ВДА 07.03.13"

< "··· СтрокаПараметров.СуммаАмортизации = СтрокаПараметров.ПервоначальнаяСтоимость"

< "· -СтрокаПараметров.НачисленнаяАмортизация;"

 

 

Роли

***- Объект изменен

-->- Объект присутствует только в конфигурации поставщика

<--- Объект присутствует только в конфигурации базы данных

^- Порядок объекта изменен

Роль «РежимВсеФункции»

- ***Роль.РежимВсеФункции

- ***Объекты

- ***БухгалтерияПредприятия_БИТ_ФИНАНС

- ***Подсистемы

- <--Объект - Бит_РусскиеБашни

- ***Роли

- <--Объект - Бит_Элетроэнергия

- <--Объект - DIADOK

- ***ОбщиеМакеты

- <--Объект - ПФ_MXL_СчетФактура451ООО

- <--Объект - ПФ_MXL_СчетФактура451ЗАО

- <--Объект - ПФ_MXL_СчетФактура1137ЗАО

- <--Объект - ПФ_MXL_СчетФактура1137ООО

- ***ОбщиеМодули

- <--Объект - БИТ_DEN_СоотвествиеСтатьИзПроводки

- ***ПодпискиНаСобытия

- <--Объект - бит_ПриЗаписиОсновногоСредства

- ***Справочники

- ***бит_ТипыДоговоров

- ***Формы

- <--Объект - БИТ_ФормаГруппы

- <--Объект - БИТ_ФормаВыбораГруппы

- <--Объект - БИТ_ФормаЭлемента

- <--Объект - БИТ_ФормаСписка

- <--Объект - БИТ_ФормаВыбора

- ***Документы

- ***бит_ДополнительныеУсловияПоДоговору

- ***Реквизиты

- <--Объект - ДоговорНаОбеспечениеЭлектроэнергии

- <--Объект - НоменклатураНаОбеспечениеЭлектроЭнергии

- <--Объект - ПроцентНадбавки

- ***Формы

- <--Объект - ВДА_ФормаСпискаУправляемая

- ***ТабличныеЧасти

- <--Объект - ПараметрыРаспределения

- ***бит_му_МодернизацияОС

- ***Формы

- <--Объект - БИТФормаДокументаУправляемая

- ***бит_му_ПринятиеКУчетуОС

- ***Формы

- <--Объект - БИТ_ФормаДокументаУправляемая

- ***ТабличныеЧасти

- ***ОсновныеСредства

- ***Реквизиты

- <--Объект - РАСХОДЫ_НА_ОПЛАТУ_ТРУДА

- <--Объект - СТРАХОВЫЕ_ВЗНОСЫ

- <--Объект - Прочие_Расходы

- <--Объект - БИТ_ПрекращениеДополнительныхУсловийПоДоговору

- <--Объект - ПоказанияСчетчиковДляЭлектроЭнергии

- <--Объект - ВыставлениеДанныхПоЭлектроЭнергии

- <--Объект - ТарифыЭлектроэнергии

- <--Объект - БИТ_МСФО_accrual

- ***Перечисления

- <--Объект - СтатусыЭлектроСнабжения

- ***Отчеты

- <--Объект - бит_СравнениеСубконтоРСБУИМСФО

- <--Объект - СравнениеСчетовРСБУиМСФО

- ***Обработки

- <--Объект - УчетВсего

- <--Объект - ЗагрузкаСтоимостиБашен

- <--Объект - ЗагрузкаДанныхПоЭлектроЭнергии

- <--Объект - ПорталВГО

- <--Объект - СозданиеПлатежныхПорученийНаАренда_и_субаренда_имущ

- <--Объект - Установка_даты_и_номеров_авансов_в_счетах_фактурах

- <--Объект - БИТ_ФормированиеПлатежныхПорученийНаУплатуНалогов

- <--Объект – ДиадокУФ

- <--Объект - КапитализацияПроцентовИзмененная

- <--Объект - ПерепроведениеПоКонтрагенту

- <--Объект - РасчетПроцентовNEW

- ***РегистрыСведений

- ***РеквизитыУплатыНалоговИПлатежейВБюджет

- ***Ресурсы

- <--Объект - КодОКАТО

- ***Измерения

- <--Объект - РегистрацияВИФНС

- ***Формы

- <--Объект - БИТ_ФормаСписка

- <--Объект - БИТФормаЗаписи

- <--Объект - РасторгаемыеДополнительныеСоглашения

- <--Объект - Electricity

- <--Объект - ПоказанияСчетчиков

- <--Объект - ВключениеАМСВСебестоимостьСтроительства

- <--Объект - СписокРасходовВключаемыхВСтоимостьСтроительства

- <--Объект - УсловияДоговоровАМС

- <--Объект - Бит_РасчетНалогаНаИмущества

- <--Объект - БИТ_СведенияОНазначенииПлатежа

- <--Объект - Бит_Сведение_Оплатежах

- <--Объект - ПоказанияСчетчиковВходящих

- <--Объект - СтатусАМСЭнергии

- <--Объект - ВремДанныеЭлектроЭнергии

- <--Объект - СтрокиДокументов

- <--Объект - АРМ_РабочегоМеста

- <--Объект - СтатусЭлектроСнабжения

- ***РегистрыНакопления

- <--Объект - Бит_ПоказанияСчетчика

 

Роль «бит_му_ПолныеПрава»

- ***Роль.бит_му_ПолныеПрава

- ***Объекты

- ***БухгалтерияПредприятия_БИТ_ФИНАНС

- ***Подсистемы

- <--Объект - Бит_РусскиеБашни

- ***Роли

- <--Объект - Бит_Элетроэнергия

- <--Объект - DIADOK

- ***ОбщиеМакеты

- <--Объект - ПФ_MXL_СчетФактура451ООО

- <--Объект - ПФ_MXL_СчетФактура451ЗАО

- <--Объект - ПФ_MXL_СчетФактура1137ЗАО

- <--Объект - ПФ_MXL_СчетФактура1137ООО

- ***ОбщиеМодули

- <--Объект - БИТ_DEN_СоотвествиеСтатьИзПроводки

- ***ПодпискиНаСобытия

- <--Объект - бит_ПриЗаписиОсновногоСредства

- ***Справочники

- ***бит_ТипыДоговоров

- ***Формы

- <--Объект - БИТ_ФормаГруппы

- <--Объект - БИТ_ФормаВыбораГруппы

- <--Объект - БИТ_ФормаЭлемента

- <--Объект - БИТ_ФормаСписка

- <--Объект - БИТ_ФормаВыбора

- ***Документы

- ***бит_ДополнительныеУсловияПоДоговору

- ***Реквизиты

- <--Объект - ДоговорНаОбеспечениеЭлектроэнергии

- <--Объект - НоменклатураНаОбеспечениеЭлектроЭнергии

- <--Объект - ПроцентНадбавки

- ***Формы

- <--Объект - ВДА_ФормаСпискаУправляемая

- ***ТабличныеЧасти

- <--Объект - ПараметрыРаспределения

- ***бит_му_МодернизацияОС

- ***Формы

- <--Объект - БИТФормаДокументаУправляемая

- ***бит_му_ПринятиеКУчетуОС

- ***Формы

- <--Объект - БИТ_ФормаДокументаУправляемая

- ***ТабличныеЧасти

- ***ОсновныеСредства

- ***Реквизиты

- <--Объект - РАСХОДЫ_НА_ОПЛАТУ_ТРУДА

- <--Объект - СТРАХОВЫЕ_ВЗНОСЫ

- <--Объект - Прочие_Расходы

- <--Объект - БИТ_ПрекращениеДополнительныхУсловийПоДоговору

- <--Объект - ПоказанияСчетчиковДляЭлектроЭнергии

- <--Объект - ВыставлениеДанныхПоЭлектроЭнергии

- <--Объект - ТарифыЭлектроэнергии

- <--Объект - БИТ_МСФО_accrual

- ***Перечисления

- <--Объект - СтатусыЭлектроСнабжения

- ***Отчеты

- <--Объект - бит_СравнениеСубконтоРСБУИМСФО

- <--Объект - СравнениеСчетовРСБУиМСФО

- ***Обработки

- <--Объект - УчетВсего

- <--Объект - ЗагрузкаСтоимостиБашен

- <--Объект - ЗагрузкаДанныхПоЭлектроЭнергии

- <--Объект - ПорталВГО

- <--Объект - СозданиеПлатежныхПорученийНаАренда_и_субаренда_имущ

- <--Объект - Установка_даты_и_номеров_авансов_в_счетах_фактурах

- <--Объект - БИТ_ФормированиеПлатежныхПорученийНаУплатуНалогов

- <--Объект - ДиадокУФ

- <--Объект - КапитализацияПроцентовИзмененная

- <--Объект - ПерепроведениеПоКонтрагенту

- <--Объект - РасчетПроцентовNEW

- ***РегистрыСведений

- ***РеквизитыУплатыНалоговИПлатежейВБюджет

- ***Ресурсы

- <--Объект - КодОКАТО

- ***Измерения

- <--Объект - РегистрацияВИФНС

- ***Формы

- <--Объект - БИТ_ФормаСписка

- <--Объект - БИТФормаЗаписи

- <--Объект - РасторгаемыеДополнительныеСоглашения

- <--Объект - Electricity

- <--Объект - ПоказанияСчетчиков

- <--Объект - ВключениеАМСВСебестоимостьСтроительства

- <--Объект - СписокРасходовВключаемыхВСтоимостьСтроительства

- <--Объект - УсловияДоговоровАМС

- <--Объект - Бит_РасчетНалогаНаИмущества

- <--Объект - БИТ_СведенияОНазначенииПлатежа

- <--Объект - Бит_Сведение_Оплатежах

- <--Объект - ПоказанияСчетчиковВходящих

- <--Объект - СтатусАМСЭнергии

- <--Объект - ВремДанныеЭлектроЭнергии

- <--Объект - СтрокиДокументов

- <--Объект - АРМ_РабочегоМеста

- <--Объект - СтатусЭлектроСнабжения

- ***РегистрыНакопления

- <--Объект - Бит_ПоказанияСчетчика

 



©2015- 2017 stydopedia.ru Все материалы защищены законодательством РФ.